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Zusammenfassung

fu:stat bietet ein neues interaktives Statistik-Paket zur explorativen
Datenanalyse an. Das Programmpaket steht im Rahmen einer FU
Campuslizenz allen Studierenden, Mitarbeitern und Mitarbeiterinnen
fiir Zwecke der Lehre und Forschung kostenlos zur Verfiigung.

Man erfahrt in dieser Beschreibung, wie man Zugang zu dieser
Software erh#lt. Anhand von fiinf Beispielen werden die wichtigsten
Elemente von dynamischen Grafiken demonstriert. Weitere Abschnitte
behandeln die Funktionalitéit von JMP, den Zugang zu Lernvideos und
Webcasts. JMP bietet Studierenden und Lehrenden zahlreiche Un-
terstiitzungsmoglichkeiten in Form von Applets, Fallbeispielen, Kurs-
materialien und einer Austauschplattform.

Im letztem Teil werden Schnittstellen zu EXCEL, SPSS, SAS und
R beschrieben. Fiir die Freunde der MAC-Welt gibt es auch eine MAC-
Version von JMP, da dieses Paket urspriinglich auf diesem Betriebssy-
stem entwickelt wurde. Zusétzlich gibt es eine kostenlose App fiir den
iPad, auf die am Schluss verwiesen wird.
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Abbildung 1: Beispiel interaktive Verkiipfung von Histogrammen

1 JMP: Ein interaktives Statistik-Paket zur
grafischen Datenanalyse

Statistische Ergebnisse wirken iiberzeugender, wenn sie iiber eine Graphik
préasentiert werden. Das Sahnehdubchen sind interaktive Graphiken, die bei-
spielsweise die Identifikation von Teilgruppen in unterschiedlichen Graphen
gestatten.

Abbildung [I] zeigt die dynamische Verkniipfung von Histogrammen mit
JMP. Hier wurden die ersten beiden Kategorien des Merkmals ”Body Fat”
markiert. Die Anteile der damit definierten Teilgruppe erscheinen in den
iibrigen Histogrammen dunkel markiert.
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Abbildung 2: Die Plattform des Graph-Builders zur Erzeugung gruppierter
Scatter-Plots

Eine zentrale Arbeitsplattform ist der Graph-Builder, mit dem gruppierte
Scatter-Plots erzeugt werden. In Abbildung [2| werden die Tagesrenditen von
BMW und Miinchner Riick iiber dem Dax abgetragen. Die eingezeichneten
Linien sind gegléittete Schétzer fiir den Erwartungswert die Einzelrenditen bei
gegebener DAX Rendite. Man erkennt sofort, dass die BMW-Rendite stéarker
auf den DAX reagiert als die Rendite der Miinchener Riick. Die Einfarbung
der Punkte zeigt die Nummer der 3245 Borsentage an. Hier ist kein Zusam-
menhang mit den Renditen zu erkennen. Der Graph-Builder steht auch als
App zur Verfiigung.
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Abbildung 3: Beispiel Mosaik-Plot

Uber einen Mosaik-Plot lassen sich anschaulich Zusammenhénge zwischen
nominalen Merkmalen darstellen. In Abbildung [3] erkennt man leicht die

Zusammenhinge zwischen Passagier-Klasse und Geschlecht bei der Uber-
lebenschance auf der Titanic.



Kapitel 5 Speichern und Freigeben der Arbeit 151
Erste Schritte mit JMP  Erstellen von Adobe Flash-Versionen der Analysediagramm- , Blasendiagramm- oder
Abbildung 3.7 Urspriinglliches Blasendiagramm
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Speichern des Blasendiagramms als .SWF-Datei

1. Wihlen Sie Fir Adobe Flash Platform (.SWF) speichern aus dem roten Dreiecksmenti.

19

Im Fenster ,Speichern unter SWE* wihlen Sie den Speicherort fiir die Datei.

Klicken Sie auf Speichern. Die Adobe Flash-Version des Blasendiagramms wird als HTML
gespeichert und erscheint in einem Webbrowser.
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Abbildung 4: Beispiel interaktiver Bubble-Plot

Die Entwicklung iiber die Zeit spielt in vielen statistischen Analysen eine
zentrale Rolle. Mit der Bubble-Plattform lassen sich neben der Zeit 4 wei-
tere Merkmale darstellen (X-Achse, Y-Achse, Grole und Farbe der Blase).
Mit einem Knopfdruck lésst sich eine dynamische Flash-Animation erzeugen.
Abbildung [4] zeigt eine solche Flash-Animation mit den entsprechenden Reg-
lern. Im Beispiel wird die Entwicklung des Anteils der Bevilkerung unter 20
Jahren zu den iiber 60-jahrigen seit 1950 dargestellt. Die einzelnen Lénder
werden nach ihrer Grosse und nach Landergruppen (Farbe) dargestellt.
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Abbildung 5: Beispiel Diskriminanzanalyse Iris Bliiten

Multivariate Analysen leben von grafischen Darstellungen. Das klassische
Beispiel der Unterscheidung von 3 Iris-Arten geréit mit der Grafik von JMP
besonders iiberzeugend, vgl Abbildung

Einen Uberblick iiber die vielen Grafik-Moglichkeiten mit JMP bietet die
folgende Galerie http://www. jmp.com/software/jmp-screenshots.shtml


http://www.jmp.com/software/jmp-screenshots.shtml

2 Was kann JMP?

JMP ist durch seine Klickoberflache ein leicht zu bedienendes Programm. Das
Analysespektrum reicht bis zu verallgemeinerten linearen Modellen, Neuro-
nalen Netzen und Regressionsbdaumen und geniigt vom Methodenniveau sehr
vielen empirischen Abschlussarbeiten auf BA- oder MA-Niveau. Da die FU-
Campuslizenz einen kostenfreien Zugang erlaubt, ist JMP eine attraktive
Alternative zu den bisherigen von fu:stat betreuten Statistikpaketen (SPSS,
SAS, STATA, EVIEWS und R).

Eine Kurzbeschreibung der wichtigsten statistischen Funktionalitdten von
JMP findet man unter diesem Link http://www.jmp.com/de/academic/
learning_library.shtml. Er verweist unter anderem auf die fiir Studie-
rende konzipierte Kurziibersicht :

e@)"r http://www.jmp.com/academic/pdf/jmpl0_se_quick_guide.pdf P-c H"f‘]MHAcad:mk “'f'JMP\ Learning Lih...|-'fJMP|Amdemic # jmp.com x ‘ | i v 83

i M Blackboard Learn (2) [0 Blackboard Leam ] CROS-portal &1 Home - Master in Survey ... (g Master of Science in Statis...

@ L]
JMP 10 Student Edition Quick Guide ‘m

Instructions presume an open data table, default preference settings, and appropriately typed, user-specified variables of interest.

RMC = Click Right Mouse Button Statistical Dtsoovery:~ From S4S.

n

What How

Frequency Distribution Analyze = Distribution (For categorical variables, frequencies are displayed. Otherwise, quantiles and moments are.)

Graph > Graph Builder > Drag Continuous Variable to Y and Categorical to X > Click Bar Icon

Bar Chart Or: Graph > Chart

Pie Chart Graph > Graph Builder > Drag Continuous Variable to Y and Categorical to X > Click Pie Icon
Or: Graph = Chart > Options > Pie Chart
Graph > Graph Builder > Drag Variable to ¥ or to X > Click Histogram Icon

Histogram N 5
Or: Analyze = Distribution

Stem and Leaf Plot Analyze > Distribution; select = Stem and Leaf

Graph = Graph Builder = Drag Continuous Variable to Y and another one to X
Scatter Plot 2D Or: Analyze > Fit Y by X (Bivariate)
Or: Graph = Qverlay Plot

Scatter Plot 3D Graph = Scatterplot 3D

Graphing

Graph > Scatterplet Matrix

Scatter Plot Matrix
Or: Analyze > Multivariate

Trellis Plot Graph = Graph Builder = Drag Column to Y and one to X; Drag Nominal or Ordinal Calumn to Wrap

Graph > Graph Builder > Drag Cont. Variable to Y and anaother one to X = Click Line Icon

Line Chart
ine tha Or: Graph = Qverlay Plot; select = y options = Connect Thru Missing

Graph > Graph Builder > Continuous column to Y = Click Box Plot Icon

Box Plot - One Level
ox Fof ne beve Or: Analyze > Distribution

Graph > Graph Builder > Continuous column to Y and categorical to X = Click Box Plot Icon

Box Plot - Two or More Levels Or: Analyze > Fit Y by X (choose continuous Y and categorical X); select i= Display Options > Box Plot

w52 ||
17122013

DE . 7

Abbildung 6: Aus dem Quick Guide der JMP Student-Edition
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Ein Lexikon der in JMP behandelten statistischen Begriffe bietet der fol-
gende Index-File http://www. jmp.com/stat-index. Zu jedem Indexeintrag
findet man einen Hinweis, auf welche Analyseplattform man wie klicken muss,
um zum Ziel zu kommen. Unter einigen Punkten ist ein Anwendungsbeispiel
zu finden, bei dem ein Datensatz mit einem entsprechenden JMP-Script ver-
kniipft wurde, das der Nutzer aktivieren und fiir seine Zwecke geeignet mo-
difizieren kann.

e — - A A BNl >

@\-‘f http://unww.jmp.com/stat-index/ LP~B¢ H ¥ Featurelndex % ‘ -?-M|m.gm_l-?-m|m l‘?‘inp-mm ‘ | ) v £
55 M Blackboard Learn (2) [0 Blackboard Leam ] CROS-portal & Home - Master in Survey ... (g Master of Science in Statis...

pTIyJMP b Buy JMP A

Feature Index
A guide to JMP" software features

With JMP installed on your PC or Mac, you can run an example of an analysis by clicking on the o]
Example Script (JSL) link. This link will download a script, which can be run in JMP software to
demonstrate the feature. Navigate this index by the letter links below or use the search box. [e]

Suggestions or feedback for this page? Contact jmpweb@jmp.com

Want to try out these example scripts for yourself and don't own a JMP license?
Download a free 30-day trial today.

A/B/C|D E/F|IGHI|JJKLIMNOPQRSTUV WX Z

#!PI) = Capability only available in JMP Pro. m = Denotes new capability in JMP 11

TERM DEFINITION EXAMPLE OF HOW TO ACCESS IN JMP
3D biplot: Gabriel A multivariate plot in principal components space, which Analyze > Multivariate Methods > Multivariate >
shows both points and rays showing variables directions Biplot

» Example Script (JSL)

3D scatterplot A three-dimensional spinnable view of your data. Graph > Scatterplot 3D

» Example Script (JSL)

A
ABCD design Screening design for mixtures. DOE > Mixture Design > Choose Mixture Design
Type > ABCD Desi
» Example Script (JSL) o= =t
accelerated failure-time models Fits a regression model to the parameters of a life Analyze > Quality and Process > Fit Life by X > Fit
distribution, such as Weibull All Distributions
» Example Script (JSL)
accelerated life test (ALT) design Used to design high stress tests; used when the time DOE > Accelerated Life Test Design
required to test the product until it fails is prohibitive.
adaptive elastic net A generalized regression estimation technique that applies Analyze > Fit Model > Personality > Generalized
#% an adaptive L1 penalty and an L2 penalty in estimating Regression > Estimation Method

parameters.

= e

Abbildung 7: Der Stat-Index listet alphabetisch die vorhandenen stat. Fea-
tures auf


http://www.jmp.com/stat-index

Aus der JMP-Dokumentation wurde der Link auf den sogenannten Capa-
bilities-Index (http://www. jmp.com/support/help/capabilities) iibernom-
men. Hier wird zu statistischen Schlagworten, z.B. Mixed Models, dargestellt,
welche Bereiche durch JMP abgedeckt werden. Dies geschieht iiber Beispiele,
die Demonstration von Grafik sowie eine Einordnung in allgemeine statisti-
sche Problemstellungen. Abbildung |8 zeigt einen Ausschnitt zum Stichwort

”Mixed Models”.
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Abbildung 8: Der Capabilities-Index fiir das Schlagwort "Mixed Models”

(Ausschnitt)


http://www.jmp.com/support/help/capabilities

3 Wie kommt man an JMP heran?

Fiir Neugierige besteht die Moglichkeit eine 30-Tage Schnupper-Version von
JMP zu nutzen. Diese kann unter dem Link http://www. jmp.com sofort
geladen werden.

Die Statistische Beratungseinheit fu:stat http://www.stat.fu.berlin.
de hat zusammen mit einer begeisterten Nutzergruppe aus einem Excellence-
Cluster der FU eine Campus-Lizenz fiir das Statistik-Paket JMP erworben.
Die FU Campus-Version kénnen alle Studierenden sowie Mitarbeiter und
Mitarbeiterinnen der FU fiir Zwecke der Lehre und Forschung nutzen. Im
Rahmen dieser Lizenz darf die Software auf dem personlichen Rechner in-
stalliert werden. Der Zugang wird iiber einen Blackboard-Kurs geregelt. Dort
sind alle notwendigen Download-Materialien sowie weitere Informationen und
Demonstationsvideos zu finden. In den Kurs fu_stat_jmp_2014 wird man
nur nach Anmeldung bei fu:stat eingeschrieben (Garystr.21, Raum 322,
Di, MI, FR nachmittag).

fu:stat bietet im Méarz zum ersten Mal eine eintégige Schulung fiir
JMP an. Anmeldungen unter:
http://www.stat.fu-berlin.de/schulungen/JMP-Grundlagen.html

4 Lernvideos, Webcasts on Demand

Da JMP im wesentlichen iiber seine graphische Oberfache bedient wird,
eignen sich Videoaufzeichnungen hervorragend als Lernanleitung. JMP un-
terstiitzt seine Nutzer mit Videos in englischer und deutscher Sprache. Diese
Videos sind kostenfrei zugénglich. Allerdings mufy man in einigen Féllen vor-
her ein User-Profile anlegen.

Ein Einfithrungsvideo und eine Auswahl weiterer Webcasts zu speziellen
Themen wie z.B. ” Statistical Discovery in Market Research” liefert der Link:
http://www. jmp.com/about/events/ondemand.

Einen Link auf deutschsprachige Préasentationen finden Sie hier:
http://www. jmp.com/de/about/events/webcasts/ondemand.shtml.

Eine deutschsprachige Einfiihrung erreichen Sie unter diesem Link:
http://www. jmp.com/de/about/events/webcasts/entrance/gettingStarted/
getting_started.shtml.
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5 Unterstiitzung bei der Lehre

Neben den zahlreichen Videos unterstiitzt JMP Lehrende mit

e Applets (JMP Add-ins): http://www. jmp.com/academic/learning_
modules.shtml]

e Fallbespielen: http://www. jmp.com/academic/case_study_library.
shtml]

e Kursmaterialien http://www. jmp.com/academic/teaching materials.
shtml/ und einer

e Austauschplattform: http://www. jmp.com/fileexchange.

6 Schnittstellen zu EXCEL, SPSS, SAS, R

Viele der zahlreichen EXCEL-Nutzer wollen auf ihre gewohnte Nutzerober-
fliche nicht verzichten. Dies ist allerdings auch nicht notwendig, da JMP
quasi nach EXCEL migriert. Uber einen speziellen Button kann innerhalb
von EXCEL die Funktionalitiat von JMP genutzt werden.
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Voreinstellungen Datentabelle Graph Verteilung ¥ nach X Modell Zeitreihe Qualitatsregelkarte | Modell erstellen/  Maodell

erstellen anpassen anpassen bearbeiten  berechnen
In JMP Gbertragen IMP-Analysediagramm erstellen ~
Bl vl Ffe | 1960 v
A B c D E F G H | J K L M M o P -
r r r r v r r v r r v r r
Income
1 1960|1961 1962 1963 1964 1965 1966 1967 1968 1969 1970 1971 1972 1973 1974
2 | Abkhazia
3 |Afghanistan
Akrotiri and
4 |Dhekelia
5 |Albania
6 |Algeria 1280,38483)| 108541461 855.947986 1128.41578 1170,3239 121501578 1127.61429 120055622 1291.86398 1359491 1436,12977 12356638 152764637 153830643 1603,34962
7 |American Samoa
8 |Andorra 18256,2701 181429851 18646,9449 19135,2966 19304,373
9 |Angola
10 [Anguilla
Antigua and
11 |Barbuda
12 | Argentina 52561 87675)| 5446, 30363 5316,67897 495621652 537546371 585561156 573331195 6633,05231 6028 12433 651536426 6611,2342 687275834 686751079 694016863 72005083
13 | Armenia
14 | Aruba
15 | Australia 9407 68508| 9451 5463 935102327 974512856 102311445 106330944 106356779 111657066 11533.0283 120917563 12708,9193 127778341 130340814 131765864 13375 9812
16 | Austria 7434 18372 7802,97255 7960,70727 §237.06053 866345452 89274607 936530613 957518356 9951.60718 10539697 110851045 11600,223 122489517 12776,9924 13255093
17 | Azerbaijan
18 | Bahamas 11926461 12558,2956 13186,1041 13856 5169 14564 4278 15374 3358 160455276 16866,147 175925456 18516,6031 16944 1771 167733243 15626,0161 16681,0827 13616133
19 | Bahrain
20 |Bangladesh 254825079 262,765635 269,532073 260,929896 281,264386 277.273311 275387064 261367787 277.183263 272977664 282254518 262,981578 224209108 230,08098 2498517
21 |Barbados 3396,94571| 3646 65478 3961,39969 3744 02265 391532559 4347 80445 45096805 4978,13129 531078177 569366773 6210 63034 642005392 646131486 6504 71066 61645324
22 |Belarus
23 | Belgium 745471654 7799,88908 8173.81846 846597962 896963255 9205.03559 9431.61409 974206281 10110,8042 10750,6446 11360,1975 117914861 12367,3926 13115,3093 13670,975
24 |Belize 950 424005 963,113762 974770724 987470819 1003,12106 102188359 104251213 106777506 1122 1418 1157 37174 1193,02891 1222 44407 1331,03017 138566494 1552 0240
25 | Benin 256978767 | 261,647222 249,212531 257,204865 270,122942 279890894 285096991 28321829 288,837583 291,597024 291,901223 281679395 293445371 297.662021 300,65560
26 |Bermuda 19588.6127 )| 20009,6258 20410,6127 20153.2849 218428102 22334.4435 25091.7321 27876,0797 279259078 283506432 295922147 30833.6921 31624,2908 32332,1073 32860034
27 |Bhutan
28 | Bolivia 694.756972| 593,326541 922 316065 959808368 983409369 1015,38711 1056,89838 1104,19753 947 554356 954182389 927,098223 950,816138 1001,86265 1033,80858 1035.5649
Bosnia and
29 |Herzegovina
30 |Botswana 237522224 246684009 256,712052 265009691 275670149 283,775052 293,305991 301,664693 323571545 361,090754 409,659702 499029217 610,175749 7155731 75167632
31 |Brazil 1447 84381 1549 41455 1581,62542 154813472 155561576 1558 14856 1578,92025 1613,13692 175171552 187441069 1988,92152 216035304 23635112 2630,91785 28020162
British Virgin
32 |Islands
33 |Brunei 23642 854
34 |Bulgaria
35 |Burkina Faso 122207837 125,226678 130.884927 127.229469 128,049627 130640003 129,029762 137,840956 139,389332 139475782 136,920414 136125848 136,499207 134,338116 14246539
36 | Burundi 116.009861| 98311239 105372971 10783755 11258149 114920646 117924234 13147157 128669383 124 650007 149,15308 151680158 140882255 149 541886 147 14453
 CETTNREN | O O O O O O O O O SO O
4k Data | About | Footnates ‘ Settings ‘ v | ® HEE] 3

MITTELWERT: 2853,386089 ANZAHL: 97 S|

Abbildung 9: Excel-Bildschirm mit importierter JMP Task-Leiste
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Wer iiber die rigide Lizenzpolitik von SPSS und hohe Lizenzgebiihren
fiir Studierende klagt, wird sich dariiber freuen, dass JMP SPSS-Systemfiles
problemlos akzeptiert.

Die interaktive Graphik von JMP ist selbst fiir eingefleischte SAS- und
R-Nutzer attraktiv. Umgekehrt kann man von einem Programm mit einer
Klickoberfliche nicht die Funktionalitéit eines universellen statistischen Pro-
grammpakets erwarten. Aus diesem Grund bietet JMP eine sehr einfache
Schnittstelle zu SAS, R und MATLAB im Rahmen der Skriptsprache JSL.
Das folgende Beispiel zeigt wie mit Hilfe der JMP-Skriptsprache das R-Paket
"boot” aufgerufen wird. Die mit R erzeugte Graphik wird dann nach JMP
importiert.

// Initialisierung von R
R InitQ);

// Benutzung von R Packages boot und Erzeugung einer R Graphik
// Bootstrap des Stichprobenmedians

R submit ("\[
library(boot)
samplemedian <- function(x,d){return(median(x([d]) ) }
data <- rnorm(50) # datensatz mit 50 Obs
b<- boot(data,samplemedian,R=500) # 500 Bootstrap replications
plot(b)
1N

// R-Graphik nach JMP holen

JMP_Plot= R Get Graphics(png);
New Window("R Bootstrap Plot", Picture Box(JMP_Plot));

// R Fenster schliessen
R Term();

Weitere Einzelheiten zu den Schnittstellen finden Sie hier: http://www.
jmp.com/Applications/analytical_apps/.
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7 Statistik auf dem Mac

JMP ist ein urspriinglich fiir Macintosh entwickeltes Programm fiir Grafik-
basierte explorative Datenanalyse. Das sieht man der schnellen und schénen
Graphik noch heute an. Auch die Skriptsprache von JMP ist erstaunlich
effizient. Aus diesem Grund steht JMP sowohl in einer Windows- als auch in
einer Mac-Version zur Verfiigung.

8 Statistik auf dem i1Pad

Es gibt eine kostenfreie App mit der Funktionalitdt des JMP Graph Buil-
der, die auf dem iPad betrieben werden kann. JMP Dateien, die bei iTunes,
Dropbox oder Google Docs gespeichert sind, konnen {iber das iPad geladen
werden. Eine Distribution der erzeugten Graphen iiber iTunes oder Email ist
ebenfalls moglich. Ein Video und weitere Einzelheiten finden Sie hier: http:
//www.jmp.com/software/jmp/jmp-graph-builder-for-ipad.shtml.
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